A
A
A
Technical Requirements PDF Print

To best view and use the sites, Learn Skills courseware has adopted the following guidelines:

  • Our course sites work on the Macintosh, Unix, and Windows platforms.
  • Although higher-speed connections are preferable for optimal delivery, slower connections, such as 28.8 kbps modems, should allow users to view most materials on the sites; however, downloading materials will take a longer period of time.
  • Supported Browsers: Learn Skills has tested the courseware with the following browsers:
    • Internet Explorer version 6.0+ (Windows)
    • Safari version 1.2.2+
    • Firefox 1.0+ (all platforms)
    • Mozilla 1.7+ (all platforms)
    NOTE: All courses can be accessed using Internet Explorer version 6.0+, but only some of our courses are accessible using Firefox 1.0+, Mozilla 1.7 + and Safari 1.2.2+. We are working on this issue to get more browsers enabled.
  • Due to rapid development in the open source world, there may be other software packages that will work as well as of any of those suggested below. We are unable to offer technical support for any of the suggested software
  • If you encounter difficulties, please contact us with the feedback form.
 
Copyright © 2017 learnskills.org. All Rights Reserved.